Issues with authentication for Active Directory/LDAP connections
Incident Report for Auth0
Postmortem

Root Cause Analysis - Issues with Authentication for Active Directory/LDAP Connections in US, EU, and AU regions - February 25th 2020

Summary

On February 25th 2020 at 13:39 UTC Auth0 began receiving customer support tickets with regard to issues related to AD/LDAP connections. Customers with credential caching disabled were seeing attempts to login via AD/LDAP fail. Calls to the /usernamepassword/login endpoint would respond with a 404 error.

The root cause of the issue was a network configuration change made as part of an operating system upgrade. This caused some assumptions which are made in our application code to no longer be valid.

For tenants with credential caching enabled, the connection would fall back on the cache, which would prevent any login issues.

This incident was resolved at 17:15 UTC.

Thank you for your understanding and patience during this incident.

Moving Forward

Auth0 has rolled back the operating system upgrade, and created a high priority task to fix the underlying application code, and implement automated testing to prevent a recurrence of this issue. The work is expected to be completed by 4th March, 2020.

Auth0 has also embarked upon a high priority project to implement additional monitoring and alerting for our AD/LDAP capability, in order to detect these issues sooner.

Timeline

13:39 UTC - First customer report of the issue was received.

13:53 UTC - The appropriate team was paged and triaging was performed.

15:30 UTC - It was identified that the issue was related to the operating system upgrade. The rollback procedure was started.

17:15 UTC - Incident was marked as resolved.

Posted Feb 26, 2020 - 23:28 UTC

Resolved
This incident has been resolved.
Posted Feb 25, 2020 - 17:15 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Feb 25, 2020 - 16:28 UTC
Update
We are continuing to work on a fix for this issue.
Posted Feb 25, 2020 - 16:18 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Feb 25, 2020 - 16:05 UTC
Update
We are still investigating this situation; from the information available and as mentioned before the issue will cause login attempts through an AD connection (that did not had caching enabled) to fail.
Posted Feb 25, 2020 - 14:44 UTC
Update
We are continuing to investigate this issue.
Posted Feb 25, 2020 - 14:28 UTC
Investigating
We are investigating reports of issues with login attempts associated with Active Directory/LDAP connections. This should be constrained to connections where caching was previously disabled.
Posted Feb 25, 2020 - 14:15 UTC
This incident affected: Auth0 Europe (PROD) (User Authentication), Auth0 Australia (PROD) (User Authentication), and Auth0 US (PROD) (User Authentication).