[Feature Disruption] User Search API in US
Incident Report for Auth0
Resolved
This incident has been resolved.
Posted Dec 01, 2017 - 01:36 UTC
Update
Indexing has caught up and the search cluster has recovered. We will continue to monitor and investigate.
Posted Dec 01, 2017 - 01:00 UTC
Monitoring
We have mitigated the search cluster issue and the errors have stopped. There will be an indexing delay while the cluster recovers. We will continue to monitor and investigate.
Posted Dec 01, 2017 - 00:43 UTC
Investigating
A percentage of requests to the Search API are failing. This does not affect authentication transactions unless you are using the Search API via a Rule or as part of your login flow.

The Search API is a replica of the primary store. Generally, it is not a good practice to add this dependency as part of a critical flow of your system. We recommend using the Get Users by Email API instead (https://auth0.com/docs/api/management/v2#!/Users_By_Email/get_users_by_email) or Get User by ID to avoid using Search for a critical flow.
Posted Dec 01, 2017 - 00:21 UTC
This incident affected: Auth0 US (PREVIEW) (Management API) and Auth0 US (PROD) (Management API).