Elevated Errors from the Authorization Extension
Incident Report for Auth0
Resolved
This incident has been resolved.
Posted Oct 22, 2019 - 23:59 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Oct 22, 2019 - 23:44 UTC
Identified
We have identified a backend workaround for this issue and have deployed it to our EU region. We are currently deploying it in our US and AU regions.
Posted Oct 22, 2019 - 21:52 UTC
Update
We have determined that the impact of the current incident is limited to customers using Auth0's Authorization Extension with S3 storage, where requests will time out. This incident is not affecting customers with Webtask Storage.

We have also detected an uptick on errors in the US and AU regions within the last 60 minutes.

Finally, Amazon, one has reported issues with their Route53 service, which could be the root cause of these timeouts. You can check the status to this potentially related issue in https://status.aws.amazon.com/

We suggest that you modify the Rule generated by the Authorization Extension to increase the timeout value as a potential workaround to these issues. However, due to the Route53 service degradation, we can not guarantee this will resolve the issue.

We will keep you posted as we find more information related to this incident. Thank you for your continued patience while we work on restoring your services.
Posted Oct 22, 2019 - 19:55 UTC
Update
We are continuing to investigate this issue. We are still unable to reproduce it in an isolated environment. We will continue to provide updates as we have them, and we apologize for any inconveniences caused.
Posted Oct 22, 2019 - 15:03 UTC
Update
We are continuing to investigate this issue.
Posted Oct 22, 2019 - 13:44 UTC
Investigating
We are currently investigating this issue.
Posted Oct 22, 2019 - 13:07 UTC
This incident affected: Auth0 US (PREVIEW) (User Authentication), Auth0 Europe (PROD) (User Authentication), Auth0 Australia (PROD) (User Authentication), Auth0 US (PROD) (User Authentication), Auth0 Europe (PREVIEW) (User Authentication), and Auth0 Australia (PREVIEW) (User Authentication).