Dashboard for EU tenants is down
Incident Report for Auth0
Resolved
This incident has been resolved.
Posted Jan 15, 2018 - 17:42 UTC
Investigating
We are currently investigating this issue.
Posted Jan 15, 2018 - 17:25 UTC