Tenant Creation Failing in Public Cloud US-4
Incident Report for Auth0
Postmortem

A root-cause analysis for this issue has been performed and is now available at: https://cdn.auth0.com/website/20240306TenantCreationFailinginPublicCloud_US4.pdf

Posted Mar 08, 2024 - 20:31 UTC

Resolved
This issue has now been fully resolved and we are no longer observing issues with new tenant creation in US-4.
Posted Mar 06, 2024 - 23:33 UTC
Monitoring
The fix for this issue has been applied and we are now monitoring the results.
Posted Mar 06, 2024 - 23:25 UTC
Update
We are in the final release stages of implementing a fix for this issue. We will provide our next update once this has completed.
Posted Mar 06, 2024 - 22:46 UTC
Update
Our Engineering team is currently awaiting the deployments which will finish resolving this issue for all customers in US4. We are continuing to work on the fix for this and we expect this to be completed within the next two hours. We will post additional updates here at that time. Our mitigation steps are in progress as expected and we are working to fully restore service to new tenant creation in US4 as quickly as possible.
Posted Mar 06, 2024 - 20:47 UTC
Update
Our mitigation steps for this issue are still in progress. We expect this may take up to 2 hours. We will provide additional updates at that time.
Posted Mar 06, 2024 - 18:06 UTC
Update
Following extensive evaluation it was determined by our Engineering team that this issue was limited in scope to tenant creation and we did not initially observe impact to any customer logins or authentication flows. We are continuing to apply a fix for this and we will provide updates here once this has been fully mitigated in Public Cloud US-4.
Posted Mar 06, 2024 - 16:11 UTC
Update
We are working on an initial fix to rectify this issue. We will confirm here once all mitigation actions have been applied and provide an additional update on this issue in 60 minutes.
Posted Mar 06, 2024 - 15:51 UTC
Update
Our Engineering team is continuing to review the mitigation steps we have identified. We will provide additional updates in approximately 30 minutes.
Posted Mar 06, 2024 - 15:25 UTC
Identified
Our Engineering team has identified a configuration which may be causing this issue and we are working further to understand the scope of impact and review necessary mitigation steps to remediate impact.
Posted Mar 06, 2024 - 15:10 UTC
Investigating
Our Engineering team is currently investigating an issue impacting tenant creation in our US4 Public Cloud Environment. We will post additional updates here as our investigation progresses
Posted Mar 06, 2024 - 15:02 UTC
This incident affected: Auth0 US-4 (PROD) (Other) and Auth0 US-4 (PREVIEW) (Other).