Rules configuration object is empty for some tenants
Incident Report for Auth0
Postmortem

We have now completed our full RCA. Please see the following link for the full details: https://cdn.auth0.com/blog/20201025-Incident-RCA.pdf

Posted Nov 06, 2020 - 20:13 UTC

Resolved
This incident has been resolved.
Posted Oct 26, 2020 - 03:27 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Oct 26, 2020 - 03:15 UTC
Identified
The issue only affects tenants with new rules configurations. Tenants who have had a rules configuration ever set before were not affected. We are working on resolving the issue.
Posted Oct 26, 2020 - 01:08 UTC
Update
We are continuing to investigate this issue.
Posted Oct 26, 2020 - 00:50 UTC
Investigating
We found an issue with `configuration` object returning empty in rules for some tenants and we are investigating it.
Posted Oct 26, 2020 - 00:40 UTC
This incident affected: Auth0 US (PREVIEW) (User Authentication), Auth0 Europe (PROD) (User Authentication), Auth0 Australia (PROD) (User Authentication), Auth0 US (PROD) (User Authentication), Auth0 Europe (PREVIEW) (User Authentication), Auth0 Australia (PREVIEW) (User Authentication), Auth0 US-3 (PROD) (User Authentication), and Auth0 US-3 (PREVIEW) (User Authentication).