Intermittent Session Timeouts in US-4 Public Cloud Environment

Incident Report for Auth0

Resolved

Services has been restored. A root cause analysis (RCA) will be posted here within 14 days. We sincerely apologize for the impact this had on you and your users.
Posted Feb 28, 2026 - 03:34 UTC

Update

The initial impact has fully recovered, and we've transitioned from active response to a dedicated monitoring phase. While we expect services to remain stable, if you experience any intermittent session timeout errors, please contact our support team for assistance.
Posted Feb 28, 2026 - 02:44 UTC

Monitoring

Our Engineering team has applied a fix, and while we're seeing clear indications of recovery, we're proceeding with an abundance of caution to ensure full stability. We will continue to monitor and will provide an update within 30 minutes or as soon as new information becomes available.
Posted Feb 28, 2026 - 02:17 UTC

Update

We are currently performing infrastructure optimizations to address performance degradation. We have refined our database configuration and are scaling up backend capacity to better manage current traffic loads. We are actively monitoring the environment to confirm that these adjustments successfully stabilize the service.
Posted Feb 28, 2026 - 01:48 UTC

Update

We are still experiencing errors. Our engineering team is actively investigating, with a current focus on reviewing system logs and telemetry to identify the root cause. We will provide an update within 30 minutes or as soon as new information becomes available.
Posted Feb 28, 2026 - 01:19 UTC

Investigating

We are currently investigating an incident that impacted our services. Impacted users would experience intermittent session timeouts. Our team is actively working to understand the root cause and mitigate the issue. We will provide updates as we gather more information.
Posted Feb 28, 2026 - 00:45 UTC
This incident affected: Auth0 US-4 (PROD) (User Authentication).