[Self-Service] Issues when upgrading or updating your subscription
Incident Report for Auth0
Resolved
This incident has been resolved.
Posted Jul 10, 2019 - 23:12 UTC
Identified
We are currently experiencing issues with self-service customers trying to upgrade or update their subscription, as our third-party provider is experiencing problems. We are awaiting a resolution from them, and will update you once we confirm this has been resolved.
Posted Jul 10, 2019 - 22:43 UTC
This incident affected: Management Dashboard (manage.auth0.com).