[Major] Elevated errors on logins
Incident Report for Auth0
Postmortem

Overview

On November 12th, 2018 between 17:50 and 18:27 UTC, 232 attempts to authenticate through Facebook (0.6% of all requests) in the EU region failed. Facebook had a service outage during this time.

Though this was due to external systems that we do not control, we would like to ensure that we always keep our customers informed of any issues that may impact them.

What Happened

System monitoring alerted us to errors related to Facebook logins in the EU region. After investigating, we discovered that Facebook was returning error pages with the message “Sorry, something went wrong. We're working on it and we'll get it fixed as soon as we can” in place of the normal authentication response, and the problem was determined to be on Facebook’s side. We attempted to check the Facebook status page, but it was also down initially. We checked our customers’ Facebook connections in other regions, and determined that EU was the only one affected during this time period.

We informed our customers of this issue via our status page and continued to monitor the errors until they stopped at 18:48 UTC. We also monitored the Facebook status page for additional information. The status page was not updated; however, sites monitoring Facebook API uptime supported evidence of an outage.

Timeline

18:14 UTC: Engineering was alerted that there was an increased amount of errors related to Facebook logins in the EU region

18:17 UTC: Engineering did a preliminary investigation into these errors and found that Facebook was displaying an error page saying “Sorry, something went wrong. We're working on it and we'll get it fixed as soon as we can" in place of the normal authentication response
18:22 UTC: Engineering formed an incident team to further investigate the situation
18:27 UTC: The Auth0 status page was updated with the incident
18:40 UTC: The incident team found that the errors had largely subsided
18:47 UTC: The incident on the Auth0 status page was updated to a status of Monitoring
19:40 UTC: The incident team found that there had been no occurrences of the error in the last 45 minutes
19:41 UTC: The incident on the Auth0 status page was updated to a status of Resolved

What Are We Doing About It?

[Active] Continue to monitor Facebook connections for errors

Posted Nov 14, 2018 - 15:33 UTC

Resolved
This incident has been resolved.
Posted Nov 12, 2018 - 19:41 UTC
Monitoring
The number of errors has reduced. It is likely that the issues were caused by problems with Facebook's API. We will continue to monitor.
Posted Nov 12, 2018 - 18:47 UTC
Investigating
A small percentage of authentication transactions using the Facebook strategy are failing to process correctly. The team is currently investigating the root cause. We'll keep you updated.
Posted Nov 12, 2018 - 18:27 UTC
This incident affected: Auth0 Europe (PROD) (User Authentication).