Increase latency in certain Authentication and Management API flows
Incident Report for Auth0
Postmortem

A root-cause analysis for this issue has been performed and is now available at https://cdn.auth0.com/blog/20210727-Incident-RCA.pdf

Posted Aug 10, 2021 - 16:36 UTC

Resolved
Based on our monitoring this situation should now be resolved.
Posted Jul 27, 2021 - 11:45 UTC
Monitoring
The situation seems to have returned to expected levels and we are no longer observing timeout issues on the flows in question. We are still monitoring and reviewing the situation.
Posted Jul 27, 2021 - 10:43 UTC
Investigating
We are currently investigating reports of increased latency and timeout in flows that leverage extensibility endpoints or depend on external calls that originate from the Auth0 service to external parties. This would include any flows that have custom extensibility code that performs external calls to other systems or to the Management API or flows that implicitly perform external calls; for example, any connections that require additional calls to be performed from the Auth0 system to the identity provider system during login.
Posted Jul 27, 2021 - 10:20 UTC
This incident affected: Auth0 Europe (PROD) (User Authentication, Machine to Machine Authentication, Management API).